0 votes

Hello,

We have earlier had a fully working program using IMAP and the LoginPlain method to obtaining access to a shared mail box. After our customer upgraded to Exchange 2016 it has stopped working giving us an exception saying: AUTHENTICATE failed.

We have used login sending parameters in this format:

imap.LoginPLAIN("alias", "user@domain", "pwd");

Do you know what could have happened?
Is there any changes in Exchange 2016 that can effect authentication?

by (400 points)
Can you try:

imap.Login(@"Username@DomainName\SharedMailboxAlias", "UserPassword");
This is not the solution!
I get this exception and stack trace:
LOGIN failed.
Stack:    at    .  (ImapResponse response)
   at    .  (ImapResponse response)
   at Limilabs.Client.IMAP.Imap.  (String user, String password)

I noticed that I wrote the wrong Exchange version. It should be Exchange 2016.
This has now been solved.
A misunderstanding between me and the network technician at our customer site. He told me the display name of the alias when we need the alias name to be able to connect. This means that our original code now works.

imap.LoginPLAIN("alias", "user@domain", "pwd");
Glad that it worked!

1 Answer

0 votes
 
Best answer

This has now been solved. A misunderstanding between me and the
network technician at our customer site. He told me the display name
of the alias when we need the alias name to be able to connect. This
means that our original code now works.

imap.LoginPLAIN("alias", "user@domain", "pwd");
by (286k points)
...