0 votes

I think we have an issue with the old library using TLS 1.0 which is now deprecated.

I see from your website that the latest version supports TLS 1.2.

Is the new library compatible with the old one as regards usage or would we need to make code changes to implement it?

Does it use the highest available TLS version on the server automatically?

by

1 Answer

0 votes

There were only 4 breaking changes since version 3.0.15362.1457, you can examine them here: https://www.limilabs.com/static/mail/ReleaseNotes.txt

In all cases, workarounds are trivial. I'm 99% sure you are not even affected, by those.

You should specify TLS versions you allow:

imap.SSLConfiguration.EnabledSslProtocols = SslProtocols.Tls11 
    | SslProtocols.Tls12;

TLS 1.2 should be the only option right now:

imap.SSLConfiguration.EnabledSslProtocols = SslProtocols.Tls12;

https://www.limilabs.com/blog/use-tls12-with-imap

by (272k points)
...